Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet disableDefender = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName in~ ("dccon.exe","defendercontrol.exe","dc.exe") or ProcessCommandLine has "Defender Control"
| project DeviceName, DisableTime = Timestamp, DisableCmd = ProcessCommandLine;
let shadowWipe = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName in~ ("vssadmin.exe","wmic.exe","bcdedit.exe")
| where ProcessCommandLine has_any ("delete shadows","shadowcopy delete","recoveryenabled no","bootstatuspolicy ignoreallfailures")
| project DeviceName, WipeTime = Timestamp, WipeCmd = ProcessCommandLine;
disableDefender
| join kind=inner shadowWipe on DeviceName
| where WipeTime - DisableTime between (0min .. 30min)
| project DeviceName, DisableTime, DisableCmd, WipeTime, WipeCmd
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.