Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet rubeus = DeviceProcessEvents
| where Timestamp > ago(1d)
| where ProcessCommandLine has_any ("Rubeus","kerberoast","asktgt","s4u")
| project DeviceName, RubeusTime = Timestamp, AccountName;
let psexec = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName in~ ("psexesvc.exe","psexec.exe")
| project DeviceName, PsExecTime = Timestamp;
rubeus
| join kind=inner psexec on DeviceName
| where PsExecTime - RubeusTime between (0min .. 4h)
| project DeviceName, AccountName, RubeusTime, PsExecTime
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.