Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet harvest = DeviceProcessEvents
| where Timestamp > ago(1d)
| where ProcessCommandLine has "SessionGopher"
| project DeviceName, HarvestTime = Timestamp, AccountName;
let implant = DeviceProcessEvents
| where Timestamp > ago(1d)
| where ProcessCommandLine has_any ("Invoke-Empire","Koadic","chashell")
| project DeviceName, ImplantTime = Timestamp;
harvest
| join kind=inner implant on DeviceName
| where ImplantTime - HarvestTime between (0min .. 8h)
| project DeviceName, AccountName, HarvestTime, ImplantTime
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.