Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceFileEventslet massRename = DeviceFileEvents
| where Timestamp > ago(1d)
| where ActionType == "FileRenamed"
| summarize RenameCount = count(), Folders = dcount(FolderPath) by DeviceName, InitiatingProcessAccountName, bin(Timestamp, 10m)
| where RenameCount > 200 and Folders > 5;
let ransomNote = DeviceFileEvents
| where Timestamp > ago(1d)
| where FileName has_any ("README","DECRYPT","How_to_restore","RECOVER")
| project DeviceName, NoteTime = Timestamp, FileName;
massRename
| join kind=inner ransomNote on DeviceName
| project DeviceName, InitiatingProcessAccountName, RenameCount, Folders, NoteTime, FileName
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.