Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet search = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName has_any ("everything.exe","es.exe")
| project DeviceName, SearchTime = Timestamp;
let transfer = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName in~ ("winscp.exe","winscp.com","megasync.exe","megacmd.exe")
| project DeviceName, TransferTime = Timestamp;
search
| join kind=inner transfer on DeviceName
| where TransferTime - SearchTime between (0min .. 4h)
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.