Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet ntds = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName =~ "ntdsutil.exe" and ProcessCommandLine has_any ("ifm","create full")
| project DeviceName, NtdsTime = Timestamp;
let lsassAccess = DeviceProcessEvents
| where Timestamp > ago(1d)
| where ProcessCommandLine has "minidump" and ProcessCommandLine has "lsass"
| project DeviceName, DumpTime = Timestamp;
ntds
| join kind=inner lsassAccess on DeviceName
| where DumpTime - NtdsTime between (-2h .. 2h)
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.