Sponsored by Hudson Rock – Use Hudson Rock's free cybercrime intelligence tools to learn how Infostealer infections are leading to ransomware attacks
DeviceProcessEventslet mailBomb = EmailEvents
| where Timestamp > ago(1d)
| summarize InboundCount = count() by RecipientEmailAddress, bin(Timestamp, 1h)
| where InboundCount > 100;
let quickAssist = DeviceProcessEvents
| where Timestamp > ago(1d)
| where FileName =~ "quickassist.exe"
| project DeviceName, AccountName, QaTime = Timestamp;
mailBomb
| join kind=inner quickAssist on $left.RecipientEmailAddress == $right.AccountName
| where QaTime - Timestamp between (0min .. 4h)
Hunting queries are starting points for threat hunting & detection engineering — validate table/column names against your own workspace schema and tune thresholds before turning any of these into a production alert rule.